End of support for Mac OS X 10.5

From Update 2.35, the DOFUS Updater will ship with its own version of Adobe Air on Mac OS X.

Once patched, the Updater will not longer support Max OS X 10.5 (Leopard).

If you are still using this version, we invite you to upgrade to Mac OS X 10.6 or a later version.

If you are unable to upgrade to a later version of the operating system, we invite you to contact our Support Team.

Have more questions? Submit a request